minitrix/flake.nix
2023-01-11 23:53:41 -06:00

21 lines
537 B
Nix

{
description = "A very basic flake";
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
flakePkgs = rec {
minitrix = pkgs.python310Packages.callPackage ./. { };
};
in rec {
packages = flake-utils.lib.flattenTree flakePkgs;
devShell = pkgs.mkShell {
inputsFrom = with packages; [ ];
packages = with pkgs.python310Packages; [ poetry yapf ];
};
});
}